For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: Proclimb M 2012 and beyond
 
 
Share Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 03-22-2018, 11:50 AM
Radar78 Radar78 is online now
Currently: Back to riding 1HP.
Join Date: Aug 2010
Location: Dundurn Sask. Canada
Posts: 332
Thanks: 100
Thanked 54 Times in 29 Posts
Rep Power: 3846558
Radar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond reputeRadar78 has a reputation beyond repute
Default Broken Pipe

I bought a carryover Ď16 LTD M8000 this year. After the first 150 miles I noticed the tab that holds the spring between the pipe and silencer had broken off of the pipe. My dealer warrantied the pipe but I noticed now after roughly 300 miles, the same tab has broken again. Anybody else ever seen this? Why is it breaking and is there a fix? Everything lines up very well so Iím kinda confused.


Sent from my iPhone using Tapatalk
Reply With Quote


Rate this post: Yes | No
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Broken turbo Y pipe springs Thread Starter — sno-addict Forum — Polaris: TURBO Replies — 5 Last Post — 01-23-2015 03:46 PM
Thread — Broken Y Pipe T1000 Thread Starter — spooled flatlander Forum — Arctic Cat: TURBO Replies — 8 Last Post — 01-15-2010 05:22 PM
Thread — Broken Y Pipe Thread Starter — zr800m1000 Forum — Performance/Modified Replies — 1 Last Post — 02-15-2009 09:11 PM
Thread — Broken Y Pipe Thread Starter — zr800m1000 Forum — Arctic Cat Replies — 0 Last Post — 02-15-2009 11:44 AM
Thread — broken aftermarket pipe Thread Starter — majesticsnow Forum — Ski-Doo Replies — 3 Last Post — 01-26-2009 07:29 PM

All times are GMT -6. The time now is 03:57 PM.












no new posts