For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: Powder Special and older 2000 and older, all models in the Powder Special chassis and older chassis models
Reply
 
Share Thread Tools Display Modes
  #1  
Old 11-10-2015, 10:51 PM
Summit97 Summit97 is offline
Currently: Not set.
Join Date: Nov 2007
Location: Pipestone Mn
Age: 52
Posts: 401
Thanks: 8
Thanked 3 Times in 3 Posts
Rep Power: 11
Summit97 is an unknown quantity at this point
Default ZR 580 EFI Flooding

I have a 97 zr580 I just put together. Won't run. Loads full of gas. Any suggestions? Has spark injectors have been checked has fuel to the rail. Tps sensor or coolant temp. Sensor? Got the sled in a box of parts. Everything is here. Starts to Fire but won't stay running.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 11-14-2015, 11:02 PM
benbow580's Avatar
benbow580 benbow580 is offline
Currently: Come on snow
Join Date: Dec 2009
Location: blackfoot id
Posts: 92
Thanks: 2
Thanked 5 Times in 5 Posts
Rep Power: 214757
benbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond reputebenbow580 has a reputation beyond repute
Default flooding

I had a 97 ps that did the same thing the coolant temp sensor was bad try holding the the throttle wide open and try to start it if it starts s most likely a temp sensor bad
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — '94 EXT 580 EFI ? Thread Starter — Lt Rascal Forum — Arctic Cat: Powder Special and older Replies — 0 Last Post — 02-11-2013 01:26 PM
Thread — '96 580 ZR EFI Thread Starter — vwheels65 Forum — Arctic Cat (Swapmeet) Replies — 1 Last Post — 01-25-2012 10:12 AM
Thread — 96 580 efi issues Thread Starter — PerformanceEnhanced Forum — Arctic Cat: Powder Special and older Replies — 1 Last Post — 11-23-2011 07:28 PM
Thread — 94 580 ext efi ? Thread Starter — 2DaMax Forum — Arctic Cat: Powder Special and older Replies — 2 Last Post — 10-19-2011 09:00 PM
Thread — Flooding EFI?? Thread Starter — kev57 Forum — Polaris: IQ Replies — 1 Last Post — 01-17-2010 10:09 AM

All times are GMT -6. The time now is 11:47 PM.