For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: M Series 2005-Current, all models in the M-series chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-07-2017, 12:36 PM
arcticcatwill arcticcatwill is offline
Currently: waiting for snow
Join Date: Nov 2007
Location: Lewiston, id
Posts: 409
Thanks: 4
Thanked 23 Times in 21 Posts
Rep Power: 1770854
arcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond reputearcticcatwill has a reputation beyond repute
Default ECU code 21?!?!?!?!

2010 m8. So I replace my knock sensor and its still throws the code. I run non E premium fuel only. Basically when it has the code active it acts like it has a rev limiter at 7800rpm. I have a polaris primary clutch with 66g weights. My buddy said his 11' m8 did the same thing when he over rev'd the motor, a sort a limp mode. Said he added weight and it quit doing it. but he couldn't remember what code he had. before i buy weights i thought id post on here.

Any input would be awesome.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-07-2017, 10:49 PM
MountainCat1 MountainCat1 is online now
Currently: Falling off in the Powder
Join Date: Oct 2015
Location: Montana
Basic Member
Age: 61
Posts: 296
Thanks: 116
Thanked 43 Times in 33 Posts
Rep Power: 1814800
MountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond reputeMountainCat1 has a reputation beyond repute
Garage
Default ECU code 21

Can't remember where to look up ECU codes, but google it, & I am sure you will find it. With that being said, it is probably a low octane sensor code. Back in 2012 Cat sent out a customer bulletin to have the ECU reflashed by dealers to fix the problem; I got one (bulletin) for my '11 CF 800. Since I was not seeing trouble codes on neither my '10 M8 nor my '11 CF 800,my dealer wisely suggested not to do the update. I am very glad that I did not do the re-flash (? non-revereseable?) I only run non-E 91 octane fuel & if there is any question re: octane, I will add a bit of AV 100 LL from the airport; AV fuel won't make a stock 2-stroke run higher HP, but it will not hurt it either. The AC re-flash pulled back the timing advance to eliminate the detonation & the ECU code. That is also one reason why the '10 & '11 800 Suzuki engines made 8 to 10 more HP than the '12 & up Suzuki 800;s! Try to find a way to increase/insure your octane @ 91 & see if the code does not return after re-setting the module. My 2 cents worth.
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
  #3  
Old 03-29-2018, 09:25 AM
mbcat mbcat is offline
Currently: Not set.
Join Date: Mar 2011
Basic Member
Age: 42
Posts: 276
Thanks: 11
Thanked 24 Times in 23 Posts
Rep Power: 1650404
mbcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond repute
Default Ecu21

My 2010 was doing this too. Ended up being lose rivets on pipe mount setting code.
Reply With Quote


Rate this post: Yes | No
  #4  
Old 03-29-2018, 05:48 PM
snopro75 snopro75 is offline
Currently: Sled is a pro...not me
Join Date: Aug 2017
Location: salem,or
Basic Member
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
snopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant futuresnopro75 has a brilliant future
Default

Watching this thread....my 11' m8 doing the same thing. I only use non-ethanol. Dealer said it coded 19x for faulty knock sensor. Ordered one beginning of mo. & it's still not here. My pipe support bracket above belt was loose also & spring was barely tight. Fixed both and still coded last weekend. Keep us posted.
Reply With Quote


Rate this post: Yes | No
  #5  
Old 03-30-2018, 06:44 AM
mbcat mbcat is offline
Currently: Not set.
Join Date: Mar 2011
Basic Member
Age: 42
Posts: 276
Thanks: 11
Thanked 24 Times in 23 Posts
Rep Power: 1650404
mbcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond reputembcat has a reputation beyond repute
Default

Knock is ecu21, check for anything that could send vibes . Even rail end caps, 11s had bumped timing over 10s I believe. Try 2deg key backwards
Reply With Quote


Rate this post: Yes | No
  #6  
Old 04-05-2018, 07:53 AM
Arcticatdan Arcticatdan is offline
Currently: getting ready for winter
Join Date: Nov 2007
Location: Newport, WA
Posts: 235
Thanks: 4
Thanked 21 Times in 19 Posts
Rep Power: 2079117
Arcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond reputeArcticatdan has a reputation beyond repute
Default

He found it, was the clutch. Changed to a know good one all problems gone.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — ECU code 02/03? Thread Starter — Buz Forum — Arctic Cat: 1100 ProClimb Replies — 1 Last Post — 02-27-2013 10:50 PM
Thread — ecu code 21 Thread Starter — JFro50 Forum — Arctic Cat: M Series Replies — 5 Last Post — 12-17-2012 03:34 PM
Thread — ECU code 21 help Thread Starter — jakey-boy Forum — Arctic Cat: M Series Replies — 2 Last Post — 04-14-2011 08:45 PM
Thread — ECU CODE 17 Thread Starter — papdog7 Forum — Arctic Cat: M Series Replies — 10 Last Post — 01-19-2011 09:35 PM
Thread — Ecu code 21 Thread Starter — crossfire 7 Forum — Arctic Cat Replies — 5 Last Post — 01-06-2011 08:56 PM

All times are GMT -6. The time now is 12:44 PM.

no new posts