For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-26-2018, 11:36 AM
cory@northof17.com cory@northof17.com is offline
Currently: Not set.
Join Date: Dec 2018
Basic Member
Age: 49
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 0
cory@northof17.com is an unknown quantity at this point
Default 2012 xf 1100 feels like brake applied on deceleration

I apologize if this question is already been asked. I just picked up a 2012 XF 1100 took it for a little test drive when I purchased it went for a small ride for maybe a mile or two as we don’t have a ton of snow here. The other day I took it out and scooting across the field if I let off on the throttle, it feels as though there’s an engine brake and I do get a small squeal noise on my clutch side just wondering if there is an engine brake on this model or what I should look for as far as trying to figure out what the issue is. Other than that it accelerates and tops out nice everything else seems fine.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 12-26-2018, 08:38 PM
0neoldfart 0neoldfart is offline
Currently: rigging instad of riding
Join Date: Nov 2007
Location: Thorsby, Alberta
Posts: 932
Thanks: 14
Thanked 397 Times in 223 Posts
Rep Power: 21474848
0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute0neoldfart has a reputation beyond repute
Default

It’s the nature of the beast - 4 strokes have engine braking that is quite pronounced, and they take a different style to ride them effectively
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to 0neoldfart For This Useful Post:
cory@northof17.com (12-26-2018)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — No reverse with brake applied? Thread Starter — 94fordguy Forum — Polaris: Pro-Ride Replies — 1 Last Post — 01-13-2016 09:09 PM
Thread — Parking Break Applied message on Xm Thread Starter — VmaX 600 Forum — Ski-Doo: XM Sleds Replies — 2 Last Post — 01-10-2014 12:01 AM
Thread — 2012 XF 1100 Turbo SP Thread Starter — catrider800 Forum — Arctic Cat (Swapmeet) Replies — 1 Last Post — 01-01-2013 09:55 AM
Thread — tach lights flash when electrical load is applied Thread Starter — rmkboy Forum — Ski-Doo: REV Sleds Replies — 5 Last Post — 02-19-2011 05:24 PM
Thread — Backfire on deceleration? Thread Starter — northcoastsleddr Forum — Yamaha: Boosted Sleds (Turbo or Supercharged) Replies — 2 Last Post — 01-09-2010 09:53 AM

All times are GMT -6. The time now is 07:01 AM.












no new posts