For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: IQ 2005-current, all models in the IQ and IQ Raw chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-29-2019, 09:06 AM
Big Ru Big Ru is offline
Currently: Not set.
Join Date: Mar 2019
Basic Member
Age: 47
Posts: 3
Thanks: 2
Thanked 0 Times in 0 Posts
Rep Power: 0
Big Ru is an unknown quantity at this point
Default 800 assault engine runs rough at idle- rpm drops

2009 800 Assault RMK- efi
The engine will start just fine, but the rpms fluctuates. Sometimes higher but mostly lower and then dies. Hard to use PERK when it wont idle right. I have good fresh gas. proper temperature new plugs. Could this be power valves?

and would this cause problems when reaching high rpms when racing across lakes and meadows? Because, the engine light will start to flash (but I never counted the flashes.....) The flashing stops when I restart the motor and it runs fine.

Thanks for any insight into the issues
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-29-2019, 09:55 AM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,109
Thanks: 101
Thanked 195 Times in 175 Posts
Rep Power: 8953700
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
Default

It doesn't sound like a power valve issue. It could be a fuel supply issue. Maybe the fuel pump is going or just a dirty fuel filter.
__________________
The older I get the better I was. In fact now that I think about it I'm a legend!

Haven't outgrown my 600 yet!

Last edited by retiredpop; 03-29-2019 at 10:12 AM.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to retiredpop For This Useful Post:
Big Ru (04-05-2019)
  #3  
Old 03-31-2019, 06:43 PM
WalterXC700Canadian WalterXC700Canadian is offline
Currently: Not set.
Join Date: Jan 2016
Location: Eastern Canada
Basic Member
Age: 43
Posts: 2
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
WalterXC700Canadian is an unknown quantity at this point
Default

More than likely your down on compression, do a compression test and replace the pistons before they explode and take out your bottom end. Those motors scrape the pistons on the intake side and will literally knife edge the piston skirt till the piston shatters or breaks off the cylinder skirt. Well known for those motors. Best fix is the cylinder shim fix.
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
The Following User Says Thank You to WalterXC700Canadian For This Useful Post:
Big Ru (04-05-2019)
Reply

Bookmarks

Tags
engine light, idle speed

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — RMK 800 idle drops when engine hot Thread Starter — Xileh Forum — Polaris: IQ Replies — 11 Last Post — 01-14-2016 04:11 PM
Thread — 11 Pro..runs good til higher rpm then kinda cuts out..drops rpm Thread Starter — OrangeKowJumper Forum — Polaris: Pro-Ride Replies — 22 Last Post — 01-12-2014 02:11 PM
Thread — Boonedocker Turbo XM runs rough at 3-5000 RPM Thread Starter — NEXP800 Forum — Ski-Doo: TURBO Replies — 21 Last Post — 05-19-2013 09:46 AM
Thread — Engine runs rough Thread Starter — Caspers62 Forum — Polaris: Pro-Ride Replies — 0 Last Post — 03-04-2013 07:24 AM
Thread — 2010 M8 Rough Engine Idle Thread Starter — Stack Forum — Arctic Cat: M Series Replies — 12 Last Post — 01-04-2010 08:34 PM

All times are GMT -6. The time now is 07:11 PM.




no new posts