For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: IQ 2005-current, all models in the IQ and IQ Raw chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-13-2019, 08:13 AM
Dans2005600rmk Dans2005600rmk is offline
Currently: Not set.
Join Date: Jan 2019
Location: Grandjunction, Co.
Basic Member
Posts: 10
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Dans2005600rmk is an unknown quantity at this point
Default Dim headlight, no dash readout?

Runs fine but now my light is dim and nothing on dash but a blinking brake light. 2007 rmk 600 h/o. Help!
thanks
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-15-2019, 08:27 AM
seef158 seef158 is offline
Currently: Not set.
Join Date: Dec 2007
Location: forest lake, mn
Basic Member
Age: 39
Posts: 30
Thanks: 4
Thanked 4 Times in 2 Posts
Rep Power: 0
seef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond reputeseef158 has a reputation beyond repute
Default

My first guess would be a voltage regulator, very common on efi sleds, not so sure on the carb models
Reply With Quote


Rate this post: Yes | No
  #3  
Old 04-16-2019, 11:16 AM
mormud mormud is offline
Currently: Not set.
Join Date: Feb 2010
Location: Munising, Mi.
Basic Member
Posts: 138
Thanks: 15
Thanked 3 Times in 3 Posts
Rep Power: 10
mormud is an unknown quantity at this point
Default

Have you figured this out? My 2009 assault is doing the same thing. New voltage regulator didn't help. I read about a relay on a 2014, but I can't find one on mine
Reply With Quote


Rate this post: Yes | No
  #4  
Old 04-18-2019, 09:38 AM
mormud mormud is offline
Currently: Not set.
Join Date: Feb 2010
Location: Munising, Mi.
Basic Member
Posts: 138
Thanks: 15
Thanked 3 Times in 3 Posts
Rep Power: 10
mormud is an unknown quantity at this point
Default

On mine voltage is good then starts dropping after about 4 minutes or so. When it gets to 7.5 gauge goes out. If I unplug hand warmers it goes up to 9. Unplug headlight and gauge it goes to 14. Put new voltage regulator and relay, and another stator from running sled. Still same result. Could it still be a bad new voltage regulator?
Reply With Quote


Rate this post: Yes | No
  #5  
Old 04-26-2019, 01:54 AM
jfs jfs is online now
Currently: Not set.
Join Date: Dec 2013
Age: 44
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
jfs is an unknown quantity at this point
Default

My 2009 Shift (carbed) dim the headlight and the dash lights and can occasionally go back to normal and then dim again. When it's warmed up it's fine so I'm thinking it's something with the stator.

My thinking is that the winding's or something shrink/expand with temperature and causing a voltage drop.
Reply With Quote


Rate this post: Yes | No
  #6  
Old 04-26-2019, 06:56 AM
TRS's Avatar
TRS TRS is online now
Currently: 2019-2020 winter on the way
Join Date: Dec 2007
Location: Cody, WY
Age: 62
Posts: 2,849
Thanks: 946
Thanked 2,637 Times in 956 Posts
Rep Power: 21474850
TRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond repute
Default

Quote:
Originally Posted by Dans2005600rmk View Post
Runs fine but now my light is dim and nothing on dash but a blinking brake light. 2007 rmk 600 h/o. Help!
thanks
This was a typical problem on the 2007 carb model. It was fixed with a new updated regulator/rectifier. Some of them will need a new dash gauge, the failure burned the gauge.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2007 rmk dim lights, no dash readouts Thread Starter — Dans2005600rmk Forum — Polaris Replies — 1 Last Post — 04-02-2019 07:34 AM
Thread — Dim Headlight, No Dash, No heated grips or throttle and bogs above 3500 RPM Thread Starter — 06700RMK Forum — Polaris Replies — 5 Last Post — 03-16-2013 12:11 AM
Thread — dim headlight on 2001 xc 120 Thread Starter — Blu Du Forum — Youth Sleds Replies — 2 Last Post — 12-20-2012 08:13 PM
Thread — Help-headlights dim & dash stopped working- 07' RMK 600HO Thread Starter — AverageJoe Forum — Polaris: IQ Replies — 6 Last Post — 12-23-2010 03:20 PM
Thread — Headlight goes dim! Help Thread Starter — irideabigpumpkin Forum — Yamaha Replies — 1 Last Post — 12-21-2008 01:05 PM

All times are GMT -6. The time now is 08:11 AM.








no new posts