For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-26-2018, 01:30 PM
Cat-man-Doo Cat-man-Doo is offline
Currently: Not set.
Join Date: Mar 2018
Basic Member
Age: 57
Posts: 24
Thanks: 3
Thanked 5 Times in 5 Posts
Rep Power: 0
Cat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond repute
Default Stupid question of the day

I can't seem to get the hood back on my '14 summit. It won't slid back far enough to line up the screws. The intake snorkel is preventing the hood from going back any further and I still need about 2 inches?????. What am I missing???
Reply With Quote


Rate this post: Yes | No
  #2  
Old 12-26-2018, 04:30 PM
146ev's Avatar
146ev 146ev is offline
Currently: throw em back!!!
Join Date: Oct 2008
Posts: 276
Thanks: 22
Thanked 36 Times in 29 Posts
Rep Power: 3184158
146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute
Default

Quote:
Originally Posted by Cat-man-Doo View Post
I can't seem to get the hood back on my '14 summit. It won't slid back far enough to line up the screws. The intake snorkel is preventing the hood from going back any further and I still need about 2 inches?????. What am I missing???


You have to connect the intake it rotates to lock down and then the sensor on the top needs to get plugged back in. You’ll also have a small clear plastic one on the chain case side.


Sent from my iPhone using Tapatalk
Reply With Quote


Rate this post: Yes | No
  #3  
Old 12-26-2018, 06:22 PM
Cat-man-Doo Cat-man-Doo is offline
Currently: Not set.
Join Date: Mar 2018
Basic Member
Age: 57
Posts: 24
Thanks: 3
Thanked 5 Times in 5 Posts
Rep Power: 0
Cat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond repute
Default

Yup, the problem is with the intake reattached, the hood still need to go back a couple inches for the screws to line up but it can't because of the intake. Its as if the intake tube is 2" too long, which of course it can't be.
Reply With Quote


Rate this post: Yes | No
  #4  
Old 12-26-2018, 09:19 PM
idahoskiguy idahoskiguy is offline
Currently: Not set.
Join Date: Feb 2008
Location: Boise, ID
Posts: 652
Thanks: 315
Thanked 137 Times in 78 Posts
Rep Power: 9997164
idahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond reputeidahoskiguy has a reputation beyond repute
Default

Have owned several Summit XMs of that vintage and never had any problems when taking the hoods/body apart and reassembling. Betting if you take all back apart the mistake will be revealed.

The Sko-Doo Parts website has diagrams of all assemblies which may be of help.

Cheers!
__________________
Spent most of my money on race cars, snowmobiles, motorcycles and women......the rest of it was just wasted.
Reply With Quote


Rate this post: Yes | No
  #5  
Old 12-27-2018, 06:52 AM
Rick E Rick E is offline
Currently: Not set.
Join Date: Nov 2016
Basic Member
Age: 70
Posts: 96
Thanks: 0
Thanked 8 Times in 8 Posts
Rep Power: 466370
Rick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond reputeRick E has a reputation beyond repute
Default

I own two of these sleds.

I'll suggest that you go slowly..... give yourself plenty of light...... and pay close attention to how the air box intake connects.

Here are some videos..... not all are good ones, so use discretion.


https://www.youtube.com/results?sear...o+hood+removal
Reply With Quote


Rate this post: Yes | No
  #6  
Old 12-27-2018, 07:14 AM
kanedog kanedog is online now
Currently: Undefeated Mountain Clutching Champ of the World!
Join Date: Oct 2008
Age: 55
Posts: 1,711
Thanks: 825
Thanked 964 Times in 477 Posts
Rep Power: 21474848
kanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond reputekanedog has a reputation beyond repute
Garage
Default

Use wd40 to assist with sliding the plastic into the rubber thingy. I put that chit on everything.
Reply With Quote


Rate this post: Yes | No
  #7  
Old 12-27-2018, 02:55 PM
Cat-man-Doo Cat-man-Doo is offline
Currently: Not set.
Join Date: Mar 2018
Basic Member
Age: 57
Posts: 24
Thanks: 3
Thanked 5 Times in 5 Posts
Rep Power: 0
Cat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond reputeCat-man-Doo has a reputation beyond repute
Default

So, I got the hood on. Not sure what I did different but it went together. Thanks to those that responded.
Reply With Quote


Rate this post: Yes | No
  #8  
Old 12-30-2018, 11:54 AM
Mort2112 Mort2112 is online now
Currently: Wishing I lived closer to the top....
Join Date: Dec 2010
Posts: 213
Thanks: 12
Thanked 82 Times in 62 Posts
Rep Power: 8257532
Mort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond reputeMort2112 has a reputation beyond repute
Default

When this happens to me it's because the tab on the front isn't seated properly. Sometimes it looks like but then when you re-seat it it will drop in and lock.


Glad you figured it out.
Reply With Quote


Rate this post: Yes | No
  #9  
Old 12-30-2018, 05:32 PM
146ev's Avatar
146ev 146ev is offline
Currently: throw em back!!!
Join Date: Oct 2008
Posts: 276
Thanks: 22
Thanked 36 Times in 29 Posts
Rep Power: 3184158
146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute146ev has a reputation beyond repute
Default

Quote:
Originally Posted by Mort2112 View Post
When this happens to me it's because the tab on the front isn't seated properly. Sometimes it looks like but then when you re-seat it it will drop in and lock.


Glad you figured it out.


Yep! Sounds like you didn’t get the front lip seated all the seat and actually slid either just above or just below the slot.


Sent from my iPhone using Tapatalk
Reply With Quote


Rate this post: Yes | No
  #10  
Old 02-19-2019, 10:03 PM
Sollly Sollly is offline
Currently: Not set.
Join Date: Jan 2018
Basic Member
Age: 52
Posts: 20
Thanks: 2
Thanked 16 Times in 6 Posts
Rep Power: 0
Sollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond reputeSollly has a reputation beyond repute
Default

The intake tube will actually collapse into where it connects into the hood which allows the hood to go on further and into place. When you pull the hood off the rubber tube extends and when it goes back on it has to "accordian" back in if that makes sense.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Stupid question Thread Starter — sledneck_03 Forum — Polaris: Pro-Ride Replies — 5 Last Post — 12-26-2013 12:31 PM
Thread — Stupid question Thread Starter — Bendy Forum — Arctic Cat: 1100 ProClimb Replies — 6 Last Post — 02-22-2013 06:36 PM
Thread — Stupid Question?? Thread Starter — mblanken881 Forum — Arctic Cat: M Series Replies — 1 Last Post — 12-05-2009 01:09 PM
Thread — Stupid question but i need to know Thread Starter — northof40 Forum — Arctic Cat Replies — 1 Last Post — 04-09-2009 07:46 AM
Thread — Here's a stupid question for everyone ... Thread Starter — Dogmeat Forum — General Snowmobiling Replies — 20 Last Post — 12-25-2008 01:45 AM

All times are GMT -6. The time now is 06:47 PM.




no new posts