For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-15-2019, 09:17 AM
RIDEFST263 RIDEFST263 is offline
Currently: Not set.
Join Date: Sep 2014
Basic Member
Age: 26
Posts: 4
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 0
RIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond reputeRIDEFST263 has a reputation beyond repute
Default Silber Turbo issues

I donít normally post on here as I can usually get all my info from searching, but I figured I should share my experience with silber.
I bought a turbo beginning of the season directly from silber for my axys 800. Received it within a couple weeks. Everything was packed great and all looked good. I got it all installed and took it for a test to find that it was leaking a good amount of oil. There was spray on the compressor side, leaking under the exhaust, and down onto the muffler.
I tried to give Justin a call with no luck so I figured I would email him. A couple days went by with no response so I went on the website and found the number to his engineer (whose number I donít see on the site anymore) he gave me some good info on things to check and mentioned that I may have over filled the turbo with oil. I also found a thread on here mentioning the same thing. So thinking that I just over filled it I continued to run it. Meanwhile 6 days after my original email to Justin he finally responded and said ďthe Turboís will do that if the sled is still in break in mode. Which mine is not.
200 or so miles later the sled still leaks oil. Almost worese then it didnít originally. So I called Justin on Monday of this week. I told him about the leak and how I reached out before and I had pictures this time that I could email him. He said to send the pictures and he would get back to me. This was 5 days ago..still no response. I tried calling again yesterday and his phone went straight to voicemail. The only other number listed now goes to some weird automation thing and then to the voicemail of a tuner.
With some help from a local turbo guy I was able to diagnosis it a little on my own. I ended up noticing that the exhaust side of the turbo was loose from the inner section as I could move the inner section back and forth. I dug into it further and removed the exhaust side to find that it had been like this for a while as it dug grooves into casting so that no matter how tight the bolts were it was still loose. Moved the 3 fasteners over one hole so it had something to grab and now itís nice and tight. Hopefully that fixes my issues
Moral of my story is that customer service from silber is severely lacking. Iím not trying to bash them. Just figured it was information that might help others when they look to purchase a turbo.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-15-2019, 04:11 PM
willjogervais willjogervais is offline
Currently: Not set.
Join Date: Mar 2011
Location: SW Minnesota
Age: 39
Posts: 432
Thanks: 184
Thanked 154 Times in 84 Posts
Rep Power: 15803047
willjogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond reputewilljogervais has a reputation beyond repute
Default

That really sucks, At least you were able to figure it out! I just installed my turbo yesterday, had a question about the ecu and coil bracket. Called Justin, went to voicemail. I didn't leave a message, figured I would just try back after a bit. Without me leaving a voicemail, he called me back about five minutes later. This is my second silber turbo I have bought from them, and have called Justin a few different times over the years and he has always gotten back to me or answered the phone. I would be upset if I were you, and imo there is no excuse for not trying to help you or figure out your problem when it is something that serious. On the other hand, I have had just the opposite experience and always have been pleased with his communication.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Silber turbo issues Thread Starter — tdchapman Forum — Ski-Doo: TURBO Replies — 9 Last Post — 01-04-2017 07:57 AM
Thread — 12 Silber turbo issues Thread Starter — ulost Forum — Polaris: TURBO Replies — 1 Last Post — 02-02-2016 10:28 PM
Thread — Silber turbo issues Thread Starter — sledking Forum — Polaris: TURBO Replies — 1 Last Post — 03-03-2012 06:52 PM
Thread — Weird idle issues, silber turbo.... Thread Starter — m1kflyingtiger Forum — Polaris: TURBO Replies — 27 Last Post — 02-29-2012 04:22 PM
Thread — Silber Turbo questions/issues Thread Starter — Turbopro Forum — Polaris: TURBO Replies — 15 Last Post — 10-30-2011 10:48 AM

All times are GMT -6. The time now is 11:19 PM.




no new posts