For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: TURBO Turbo discussion for Polaris aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 06-19-2019, 07:18 PM
Cbsneed4speed Cbsneed4speed is online now
Currently: Awaiting snowcheck!!
Join Date: Feb 2019
Location: Mountain Home Idaho
Basic Member
Age: 41
Posts: 13
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 0
Cbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond repute
Default 2012 BD PRO no spark

I've got a 2012 Pro with a boondocker turbo kit and on our last ride it started running like it was running on one cylinder and would stall out. We headed back to the truck and it started running fine the rest of the way back. It started and rode off the trailer and into the garage fine. I was going to take it in to the shop to have some programming done on the boondocker box but now it won't start. When you pull it over the lights light up and the boondocker box lights up but I've got no spark and no power to the main dash. Any suggestions where to start? I don't wanna pay the dealer to get it running and program the boondocker box if I can get it running again. Any help would be greatly appreciate!

Last edited by Cbsneed4speed; 06-19-2019 at 07:20 PM.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 06-21-2019, 06:25 PM
Spaarky Spaarky is offline
Currently: Moved Into Maximum Security Cell
Join Date: Oct 2001
Location: Chester, SD
Posts: 3,354
Thanks: 858
Thanked 947 Times in 589 Posts
Rep Power: 0
Spaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond reputeSpaarky has a reputation beyond repute
Default

Unplug the bd box and hook up ecu stock. See if it fires. Some of the older boxes had issues with the red wire. Sounds exactly like that.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to Spaarky For This Useful Post:
Cbsneed4speed (07-09-2019)
  #3  
Old 06-21-2019, 10:33 PM
Cbsneed4speed Cbsneed4speed is online now
Currently: Awaiting snowcheck!!
Join Date: Feb 2019
Location: Mountain Home Idaho
Basic Member
Age: 41
Posts: 13
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 0
Cbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond repute
Default

I will give that a try and see what happens. Thanks for the suggestion!!
Reply With Quote


Rate this post: Yes | No
  #4  
Old 06-23-2019, 07:14 PM
Cbsneed4speed Cbsneed4speed is online now
Currently: Awaiting snowcheck!!
Join Date: Feb 2019
Location: Mountain Home Idaho
Basic Member
Age: 41
Posts: 13
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 0
Cbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond repute
Default

No such luck with it firing up without the BD box
Reply With Quote


Rate this post: Yes | No
  #5  
Old 06-24-2019, 10:55 AM
05rmksteve's Avatar
05rmksteve 05rmksteve is online now
Currently: Putting sleds together
Join Date: Sep 2008
Location: Brainerd, MN
Age: 45
Posts: 1,423
Thanks: 91
Thanked 394 Times in 242 Posts
Rep Power: 21474848
05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute05rmksteve has a reputation beyond repute
Default

I had a 12 do this exact same thing it was the voltage regulator.
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
The Following User Says Thank You to 05rmksteve For This Useful Post:
Cbsneed4speed (06-24-2019)
  #6  
Old 06-24-2019, 07:41 PM
TRS's Avatar
TRS TRS is online now
Currently: 2019-2020 winter on the way
Join Date: Dec 2007
Location: Cody, WY
Age: 62
Posts: 2,847
Thanks: 946
Thanked 2,637 Times in 956 Posts
Rep Power: 21474850
TRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond reputeTRS has a reputation beyond repute
Default

Quote:
Originally Posted by Cbsneed4speed View Post
No such luck with it firing up without the BD box
Just a question, did you plug the injectors back into the stock harness along with the TPS?
If the speedo wires behind the secondary are rubbed through and grounding on the chassis or secondary you will get these symptoms. I fixed one in ‘13.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to TRS For This Useful Post:
Cbsneed4speed (07-09-2019)
  #7  
Old 06-25-2019, 07:27 AM
Snow Duck's Avatar
Snow Duck Snow Duck is offline
Currently: Trees are not for me!!or my son..
Join Date: Aug 2009
Location: Kuna Idaho to Elk City Idaho..
The Great and Mighty SnowDuck
Age: 46
Posts: 3,325
Thanks: 1,276
Thanked 1,091 Times in 664 Posts
Rep Power: 21474849
Snow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond reputeSnow Duck has a reputation beyond repute
Garage
Default

He is picking up a voltage regulator ECM and Coils from me today to try we will see if he gets it with one of these items.
__________________
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to Snow Duck For This Useful Post:
Cbsneed4speed (07-09-2019)
  #8  
Old 07-09-2019, 05:40 PM
Cbsneed4speed Cbsneed4speed is online now
Currently: Awaiting snowcheck!!
Join Date: Feb 2019
Location: Mountain Home Idaho
Basic Member
Age: 41
Posts: 13
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 0
Cbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond repute
Default

Ok so problem fixed!! And huge thanks to SnowDuck for hooking me up with some parts to throw at it. After none of the replacement parts got her running again I started rechecking for loose wires. I swear the first thing my buddy and I checked was the kill switches. ****s and giggles I decided to try them again. Turned out that the tether we added doesn't work. As soon as I unplugged the wires for it the sled came to life with the first pull!!! Now I feel dumb but she's alive again. Anybody want to buy it so I've got a bigger down payment on my snowchecked Khaos?? Haha
Reply With Quote


1 out of 1 members found this post helpful. Rate this post: Yes | No
The Following User Says Thank You to Cbsneed4speed For This Useful Post:
Sheetmetalfab (07-09-2019)
  #9  
Old 07-09-2019, 06:03 PM
Sheetmetalfab's Avatar
Sheetmetalfab Sheetmetalfab is online now
Currently: Boost is addictive
Join Date: Oct 2010
Location: Ak
Age: 33
Posts: 4,788
Thanks: 2,763
Thanked 1,600 Times in 1,009 Posts
Rep Power: 21474849
Sheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond repute
Default

Quote:
Originally Posted by Cbsneed4speed View Post
Ok so problem fixed!! And huge thanks to SnowDuck for hooking me up with some parts to throw at it. After none of the replacement parts got her running again I started rechecking for loose wires. I swear the first thing my buddy and I checked was the kill switches. ****s and giggles I decided to try them again. Turned out that the tether we added doesn't work. As soon as I unplugged the wires for it the sled came to life with the first pull!!! Now I feel dumb but she's alive again. Anybody want to buy it so I've got a bigger down payment on my snowchecked Khaos?? Haha
Always check the simple things first. 😂
__________________
Try again
Reply With Quote


Rate this post: Yes | No
  #10  
Old 07-09-2019, 07:07 PM
Cbsneed4speed Cbsneed4speed is online now
Currently: Awaiting snowcheck!!
Join Date: Feb 2019
Location: Mountain Home Idaho
Basic Member
Age: 41
Posts: 13
Thanks: 5
Thanked 1 Time in 1 Post
Rep Power: 0
Cbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond reputeCbsneed4speed has a reputation beyond repute
  #11  
Old 07-09-2019, 08:13 PM
Sheetmetalfab's Avatar
Sheetmetalfab Sheetmetalfab is online now
Currently: Boost is addictive
Join Date: Oct 2010
Location: Ak
Age: 33
Posts: 4,788
Thanks: 2,763
Thanked 1,600 Times in 1,009 Posts
Rep Power: 21474849
Sheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond reputeSheetmetalfab has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

The Following User Says Thank You to Sheetmetalfab For This Useful Post:
Cbsneed4speed (07-09-2019)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2012 turbo spark plug Thread Starter — Goodwinj Forum — Polaris: TURBO Replies — 2 Last Post — 02-22-2018 10:38 PM
Thread — 2012 600 pro rmk spark plugs Thread Starter — rilesman5 Forum — Polaris: Pro-Ride Replies — 1 Last Post — 01-10-2015 09:02 PM
Thread — 2012 pro spark plug question Thread Starter — m8vohkman Forum — Polaris: Pro-Ride Replies — 2 Last Post — 03-10-2014 08:26 PM
Thread — 2012 and 2013 spark plugs interchange? Thread Starter — toofpaste Forum — Polaris: Pro-Ride Replies — 2 Last Post — 12-22-2012 07:16 PM
Thread — Video on diagnosing no spark, low spark or intermitten spark condition on 1990's Cats Thread Starter — Blaine Forum — Arctic Cat: Powder Special and older Replies — 0 Last Post — 12-29-2009 09:56 PM

All times are GMT -6. The time now is 08:01 PM.








no new posts