For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: TURBO Turbo discussion for Arctic Cat aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-09-2014, 05:28 PM
09snopro's Avatar
09snopro 09snopro is online now
Currently: Not set.
Join Date: Apr 2008
Location: Shelley, ID
Posts: 121
Thanks: 19
Thanked 16 Times in 9 Posts
Rep Power: 877412
09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute09snopro has a reputation beyond repute
Default 09 M1000 Turbo Problems

K here is my problem as best described. I have a 09 M1000 pump gas turbo some OVS and some Boondocker parts. I am running the Boondocker 3D box now. If I pull the throttle 3/4 it runs out about 7500-7600 rpms and doesn't miss a beat if I pin it full throttle it will then fall down to 6600 rpm and feel like it is loading up. Air/Fuel is close to 12-12.4 when I am pulling a hill. I am running iridium plugs and did change them with no luck also running 40% 111 octane and 60% 91 octane at 7 lbs of boost. Watch the videos and hopefully we can get this diagnosed. Thanks

http://youtu.be/xNuZLXT13xw

http://youtu.be/dQy6mxQp9L4

http://youtu.be/RhFRaNNp4b8




Sent from my iPhone using Tapatalk
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-09-2014, 11:07 PM
never enough snow never enough snow is offline
Currently: Not set.
Join Date: Dec 2008
Posts: 244
Thanks: 5
Thanked 33 Times in 31 Posts
Rep Power: 0
never enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond reputenever enough snow has a reputation beyond repute
Default

power valve cable ?
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-24-2014, 10:30 PM
Sparx Sparx is offline
Currently: All I keep hearing is wrenching ratchet sounds in my head....
Join Date: Dec 2007
Location: Fort McMurray, Alberta
Age: 38
Posts: 373
Thanks: 38
Thanked 23 Times in 14 Posts
Rep Power: 0
Sparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond reputeSparx has a reputation beyond repute
Default

Sounds too rich and "cold" like, like there's too much Octane for what you need and the extra splash of fuel has that rich effect. The A/F ratio may be okay but the EGT's are diving when you splash the cylinders with that extra fuel and cooling the pipe down as well.

Does it seem like the sled doesn't have the symptoms as much when it's super hot? It might be helping with that effect as a result. The hotter the motor and exhaust the easier it is to burn off the extra fuel. Super rich conditions can also cause high EGT / A/F ratio numbers. Alot of it is in the "feel" of tuning more than numbers. You can tell when a sled runs clean so make some small changes slowly working up from your area that is running good. I would pull 5 pts off the mid and top from the settings 7500rpm and above, maybe a bit on the below setting like 7200rpm. If it helps but not quite there, try pulling an extra 2 pts off the mid and top more at the 7500rpm.

So many people mix their ratios too much nowadays and should stick to a certain "known' mixture. Mixing premium from one brand station to the next with your Race gas can cause runability issues. If your pushing the boundaries of your fuel try something known and constant like AV gas. There's very little if any variance in this fuel from one Airport to another. It can be trusted and you can get more consistency from your tuning this way.
I have never liked mixing race with premium for this main reason. At least if you are going to go this route do a full barrel at a time, then pump from the barrel to jerry cans...

M1000's are super picky on pipe temps, even more so turbo'd. Let them warm up good, and keep the pipe hot and you will see some better performance results. This can be helped with coated pipes or exhaust wrapped pipes as well, especially when your running a mesh hood like you are. I found that made a big difference to my sleds running the mesh hoods. I love them, but they cool the pipes down super fast as a result and can affect how clean the sled responds to throttle changes....
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 09 M1000 problems list Thread Starter — WyoBoy1000 Forum — Arctic Cat: M Series Replies — 28 Last Post — 02-22-2010 04:13 PM
Thread — List your '09 M1000 Problems Thread Starter — Blue Light Forum — Arctic Cat: M Series Replies — 17 Last Post — 03-29-2009 02:54 PM
Thread — M1000 turbo problems Thread Starter — cpatts2000 Forum — Performance/Modified Replies — 5 Last Post — 03-17-2009 09:49 PM
Thread — 09 m1000 problems Thread Starter — powder pounder Forum — Arctic Cat Replies — 16 Last Post — 02-10-2009 03:11 AM
Thread — M1000 turbo problems Thread Starter — sledhed88 Forum — Performance/Modified Replies — 42 Last Post — 01-23-2009 04:14 PM

All times are GMT -6. The time now is 08:03 PM.












no new posts