For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 01-26-2016, 09:52 AM
RMKrider700 RMKrider700 is offline
Currently: Not set.
Join Date: Dec 2007
Age: 39
Posts: 55
Thanks: 1
Thanked 0 Times in 0 Posts
Rep Power: 11
RMKrider700 is an unknown quantity at this point
Default Chatterbox X1 talk to BCA link radio?

I have done a lot of reading and it seems like the two radios should talk to each other but I cant get my voice to come across the BCA link radio. I can hear it key, "clicking noise" in my helmet but no voice comes across from the BCA to the chatterbox. I can talk to the chatterbox and hear it come across the BCA. Any help would be appreciated. P.S. the channels are both set the same. Thanks!
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-01-2016, 12:51 PM
mssdriver8 mssdriver8 is offline
Currently: Not set.
Join Date: Dec 2010
Location: Washington
Basic Member
Posts: 35
Thanks: 0
Thanked 8 Times in 4 Posts
Rep Power: 0
mssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond reputemssdriver8 has a reputation beyond repute
Default

My x1 slim works fine with the BCA radios.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 10-27-2016, 09:42 AM
blastco2 blastco2 is offline
Currently: Not set.
Join Date: Dec 2012
Location: se idaho
Posts: 222
Thanks: 70
Thanked 47 Times in 39 Posts
Rep Power: 4940200
blastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond reputeblastco2 has a reputation beyond repute
Default

Sounds like a problem with the ctcss tone system (sub channels). Set the sub channels to 0. Google ctcss so that you understand what you are working with.
https://en.m.wikipedia.org/wiki/Cont...Squelch_System

Last edited by blastco2; 10-27-2016 at 09:48 AM.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — BC Link Radio Rentals Thread Starter — mtnpull Forum — Utah Replies — 0 Last Post — 01-16-2016 03:13 PM
Thread — BCA Link Radio's +FREE Gift Thread Starter — Blown Motor Forum — General Snowmobiling Replies — 7 Last Post — 10-07-2015 07:16 PM
Thread — BCA Link Radio's +FREE Gift Thread Starter — Blown Motor Forum — Blown Motor Replies — 0 Last Post — 10-02-2015 10:29 AM
Thread — BCA BC Link Radio Thread Starter — christopher Forum — Communications - Radios Replies — 0 Last Post — 10-15-2013 06:13 PM
Thread — Snowmobile Radio podcast-Zen Talk Thread Starter — zis Forum — General Snowmobiling Replies — 1 Last Post — 08-30-2009 10:09 PM

All times are GMT -6. The time now is 02:10 PM.

no new posts