For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-15-2016, 01:51 PM
Clayton.Mortimer Clayton.Mortimer is offline
Currently: pow
Join Date: Mar 2016
Basic Member
Age: 33
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Clayton.Mortimer is an unknown quantity at this point
Default Blowing 30A Battery Fuse, Short?

My first problem was the machine had no power because the fuse fell out, yes, somehow it fell out. So I stuck it back in and hooked up the battery for a second and found I had power. I then let it sit for a week before coming back to it to hook everything up and go shred. But now the fuse keeps blowing.

I've tried diagnosing the problem by unplugging everything and hooking up the battery, but still 'pop' goes the fuse.

I have a wiring diagram and a multi-meter but I am still having a hard time with this.

I have unwrapped portions of the wiring harness and I have found no problems yet, seems like the next step is going to be pulling the tank off.

Any suggestions anyone?

(2013 m1100)
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-15-2016, 06:43 PM
Clayton.Mortimer Clayton.Mortimer is offline
Currently: pow
Join Date: Mar 2016
Basic Member
Age: 33
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Clayton.Mortimer is an unknown quantity at this point
Default Bad Voltage Regulator

I examined the wiring harnesses as best I could, pulled the fuel tank and could not find any damage. Based on the wiring diagram I knew the voltage regulator was in play. I performed a standard VR test and it was clear that the regulator is toast. Hopefully this is the only problem. I believe the VR was damaged by running the machine for a while with the battery fuse dislocated.

I have to give a shout out to Woody for helping me solve some of the problems I've had with this sled.

Now I am wondering if I can buy a different VR for this machine. OEM price is $100. Aftermarket ones are less than half the price and appear to be higher quality.

Any thoughts?
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-15-2016, 08:28 PM
Hotchief's Avatar
Hotchief Hotchief is offline
Currently: BOOOSTED
Join Date: Nov 2005
Location: Normandy Park, WA
Age: 51
Posts: 404
Thanks: 195
Thanked 62 Times in 32 Posts
Rep Power: 2883699
Hotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond reputeHotchief has a reputation beyond repute
Thumbs up

Woody is the man.
__________________
12' M1100T 162 Evo Mod
07' M1000 162
05' M6 153
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Blowing Fuse - M1100T Thread Starter — Hotchief Forum — Arctic Cat: 1100 ProClimb Replies — 4 Last Post — 03-25-2012 09:33 PM
Thread — nytro keeps blowing a fuse. Thread Starter — alaskamax Forum — Yamaha: 4-Stroke Replies — 4 Last Post — 10-31-2011 10:18 PM
Thread — 20 amp ignition fuse keeps blowing Thread Starter — Yaya180 Forum — Yamaha: Boosted Sleds (Turbo or Supercharged) Replies — 6 Last Post — 02-20-2011 01:06 AM
Thread — blowing the 30amp fuse??? Thread Starter — niko Forum — Ski-Doo: REV Sleds Replies — 0 Last Post — 08-30-2010 11:57 PM
Thread — Keep blowing fuse Thread Starter — bigbird Forum — Ski-Doo Replies — 1 Last Post — 02-26-2009 02:29 PM

All times are GMT -6. The time now is 03:28 PM.












no new posts