For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: IQ 2005-Current, all models in the IQ and IQ Raw chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-10-2018, 08:12 PM
switchback 6000 switchback 6000 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Age: 47
Posts: 9
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 0
switchback 6000 is an unknown quantity at this point
Default Lost dash,and all lights.

Was riding my 09 switchback 600 today and lost power,pulled over sled still idling,noticed lost all gauges and lights.Towed sled home,tried starting just cranks.found a relay located by voltage regulator and pulled it from plug and tried starting,sled fired right up but still no gauges or lights,reinstalled relay and sled started idling up higher and higher.Been reading some posts in here and have checked a few things like checked vr with a meter and was getting 13.5 volts idling(not sure if i was checking in the right spot though)There is a plug coming from stator harness and a plug coming out of vr thats where i checked it at brown AND RED WIRE.Also i pulled ecu to see if it was burnt underneath and it was ok.Any help much appreciated.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-24-2018, 04:03 PM
switchback 6000 switchback 6000 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Age: 47
Posts: 9
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 0
switchback 6000 is an unknown quantity at this point
Default

Thanks for all the help here!!
Reply With Quote


Rate this post: Yes | No
  #3  
Old 03-06-2018, 06:37 PM
seef158 seef158 is offline
Currently: Not set.
Join Date: Dec 2007
Location: forest lake, mn
Basic Member
Age: 38
Posts: 21
Thanks: 4
Thanked 1 Time in 1 Post
Rep Power: 0
seef158 is an unknown quantity at this point
Default

I'm sure you'll get a lot of responses after your last post. We just forgot that we all owe you a response. I'm sure when he'll freezes over we will remember how you are entitled, then your help will flood in.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to seef158 For This Useful Post:
switchback 6000 (03-09-2018)
  #4  
Old 03-07-2018, 06:14 PM
bigrig bigrig is offline
Currently: Not set.
Join Date: Jan 2008
Location: LAKE PARK, IA
Age: 56
Posts: 155
Thanks: 122
Thanked 27 Times in 18 Posts
Rep Power: 396894
bigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond reputebigrig has a reputation beyond repute
Default

Sounds like regulator. Replace with newest version, I can't remember part no. Been talked about on here about 2000 times. Probably burn't ecm. Rode Polaris forever, moved on to other brands. My Polaris stable is saved just for home now. Keep riding!!
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to bigrig For This Useful Post:
switchback 6000 (03-09-2018)
  #5  
Old 03-10-2018, 11:09 AM
XCaSSAULT XCaSSAULT is offline
Currently: Go Wild!
Join Date: Dec 2016
Basic Member
Posts: 223
Thanks: 40
Thanked 35 Times in 28 Posts
Rep Power: 2330249
XCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond reputeXCaSSAULT has a reputation beyond repute
Default

Have u tried replacing that relay? Take it to auto part store and they’ll find ya the same thing.
Reply With Quote


Rate this post: Yes | No
  #6  
Old 03-14-2018, 02:33 PM
switchback 6000 switchback 6000 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Age: 47
Posts: 9
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 0
switchback 6000 is an unknown quantity at this point
Default

Yes i replaced the relay.Same issue.the voltage regulator and the stator ohm out ok according to polaris.Could be ecu,but cant find any way of testing it in polaris service manual.
Reply With Quote


Rate this post: Yes | No
  #7  
Old 03-21-2018, 08:49 PM
mtnangler mtnangler is offline
Currently: Not set.
Join Date: Dec 2009
Basic Member
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
mtnangler is an unknown quantity at this point
Default IQ chassis loosing power to lights and gauge

I just went thru the same issues with a 2009 800 CFI.. Lost all lights and gauges.. Lost power to engine.. Replaced Regulator, Chassis relay and stator... Still NO lights.. But it ran better..

Put on a new wire harness and "let there be light" everything works. Haven't found exactly where the bad wire was yet... Everything works again.. till it breaks again..

The Stator and Regulator had good OHM's.. before I started.. but, since I had them in stock, thought it wouldn't hurt to replace them since they where OLD anyhow..

I heard these wire harnesses where "cheap" like most of the electrical on the IQ Polaris...
Reply With Quote


Rate this post: Yes | No
  #8  
Old 03-25-2018, 12:58 PM
switchback 6000 switchback 6000 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Age: 47
Posts: 9
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 0
switchback 6000 is an unknown quantity at this point
Default

Nice to hear yours is working!How much was the harness?
Reply With Quote


Rate this post: Yes | No
  #9  
Old 04-14-2018, 09:50 AM
switchback 6000 switchback 6000 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Age: 47
Posts: 9
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 0
switchback 6000 is an unknown quantity at this point
Default

Update--replaced stator and updated voltage regulator and still no lights or gauges.
Reply With Quote


Rate this post: Yes | No
  #10  
Old 04-14-2018, 03:02 PM
switchback 6000 switchback 6000 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Age: 47
Posts: 9
Thanks: 3
Thanked 1 Time in 1 Post
Rep Power: 0
switchback 6000 is an unknown quantity at this point
The Following User Says Thank You to switchback 6000 For This Useful Post:
retiredpop (04-14-2018)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Dash Lights Thread Starter — Newfy Forum — Polaris: 900 Replies — 1 Last Post — 01-09-2012 09:48 AM
Thread — need help with skidoo dash lights Thread Starter — rev800 Forum — Ski-Doo Replies — 3 Last Post — 03-02-2011 08:52 PM
Thread — 08 D7 No Dash Lights at low RPMS Thread Starter — Boat2Sled Forum — Polaris: IQ Replies — 4 Last Post — 12-12-2010 09:40 PM
Thread — Dash lights going out on 2005 2500HD? Thread Starter — Dogmeat Forum — Trucks and Trailers Replies — 6 Last Post — 10-02-2010 06:07 PM
Thread — 07 800r has no lights brake light, dash Thread Starter — luckylawnboy Forum — Ski-Doo: REV Sleds Replies — 5 Last Post — 12-27-2009 10:12 AM

All times are GMT -6. The time now is 11:20 AM.