For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: Pro-Ride 2010 and up, all models in the Pro-Ride chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-07-2012, 06:02 PM
HouseCO HouseCO is offline
Currently: Ready to Ride!
Join Date: Oct 2010
Location: Arvada, CO
Basic Member
Age: 39
Posts: 26
Thanks: 8
Thanked 4 Times in 2 Posts
Rep Power: 0
HouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond repute
Default New Belt Squeal

Just put on a new belt and at idle every so often i hear a squeal. what is causing this?
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-07-2012, 06:10 PM
bootz1981 bootz1981 is offline
Currently: Not set.
Join Date: Apr 2008
Location: hazen , nd
Age: 37
Posts: 719
Thanks: 172
Thanked 258 Times in 140 Posts
Rep Power: 21474847
bootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond repute
Default

i washed my belt and cleaned my clutches and loosend my deflection just a bit and the noice went away for me, i think my deflection was to tight
Reply With Quote


Rate this post: Yes | No
  #3  
Old 02-07-2012, 06:12 PM
seth25 seth25 is offline
Currently: Waiting for snow...Getting impatient
Join Date: Jan 2008
Location: Sedalia, CO
Posts: 1,188
Thanks: 419
Thanked 128 Times in 80 Posts
Rep Power: 0
seth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond reputeseth25 has a reputation beyond repute
Default

Belt tension too tight. Loosen the nut on the face of the secondary with the torx head bolt sticking out of it. Screw in the torx bolt just a little, tighten nut, and you should be good.
Reply With Quote


Rate this post: Yes | No
  #4  
Old 02-07-2012, 06:12 PM
skibreeze's Avatar
skibreeze skibreeze is offline
Currently: Loving the new Silber external wastegate turbo!
Join Date: Dec 2005
Location: Colorado Springs
Age: 48
Posts: 10,463
Thanks: 1,068
Thanked 2,014 Times in 1,214 Posts
Rep Power: 21474859
skibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond reputeskibreeze has a reputation beyond repute
Default

Belt deflection is too tight, read your owners manual.
__________________
http://avalanche.state.co.us/
Reply With Quote


Rate this post: Yes | No
  #5  
Old 02-07-2012, 06:19 PM
HouseCO HouseCO is offline
Currently: Ready to Ride!
Join Date: Oct 2010
Location: Arvada, CO
Basic Member
Age: 39
Posts: 26
Thanks: 8
Thanked 4 Times in 2 Posts
Rep Power: 0
HouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond reputeHouseCO has a reputation beyond repute
Default

Thanks all i'll give it a go..
Reply With Quote


Rate this post: Yes | No
  #6  
Old 02-07-2012, 06:27 PM
300rummt 300rummt is offline
Currently: hammershlogen
Join Date: Dec 2011
Location: SW, MT
Posts: 31
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute300rummt has a reputation beyond repute
Default

Make sure you have the clutch spread all the way with your tool or you will snap that little screw off in side the clutch
Reply With Quote


Rate this post: Yes | No
  #7  
Old 02-07-2012, 10:11 PM
bootz1981 bootz1981 is offline
Currently: Not set.
Join Date: Apr 2008
Location: hazen , nd
Age: 37
Posts: 719
Thanks: 172
Thanked 258 Times in 140 Posts
Rep Power: 21474847
bootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond reputebootz1981 has a reputation beyond repute
Default

Quote:
Originally Posted by 300rummt View Post
Make sure you have the clutch spread all the way with your tool or you will snap that little screw off in side the clutch
X2
Reply With Quote


Rate this post: Yes | No
  #8  
Old 02-07-2012, 11:56 PM
milo303 milo303 is offline
Currently: Living in Paradise
Join Date: Sep 2011
Location: Littleton
Posts: 817
Thanks: 8
Thanked 128 Times in 101 Posts
Rep Power: 0
milo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond reputemilo303 has a reputation beyond repute
Default

Quote:
Originally Posted by 300rummt View Post
Make sure you have the clutch spread all the way with your tool or you will snap that little screw off in side the clutch

Good to know, I adjusted mine without spreading the clutch.

Luckily I had no problems, but I could see it being one
Reply With Quote


Rate this post: Yes | No
  #9  
Old 02-08-2012, 04:54 PM
Grizzly Mtn Grizzly Mtn is offline
Currently: loving my pro rmk
Join Date: Jan 2009
Location: Central Oregon
Posts: 51
Thanks: 0
Thanked 5 Times in 5 Posts
Rep Power: 0
Grizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond reputeGrizzly Mtn has a reputation beyond repute
Default

I had the same problem adjusted belt deflection no issue now. The manual says 1 1/4 inches deflection it sure seems like alot to me. I went a little less than that but seem to be having no problems now. Good luck. Make sure you use your clutch tool to take pressure off clutch. Mine went easy without doing it but have seen some not so lucky...
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Belt squeal Thread Starter — Wire4Money Forum — Arctic Cat: M Series Replies — 9 Last Post — 01-24-2011 04:59 PM
Thread — Apex belt squeal Thread Starter — b_sandgren Forum — Yamaha: 4-Stroke Replies — 9 Last Post — 11-29-2010 01:38 PM
Thread — traditional yammi belt squeal Thread Starter — Ringer Forum — Yamaha: Boosted Sleds (Turbo or Supercharged) Replies — 21 Last Post — 01-05-2010 01:14 PM
Thread — Belt or clutch Squeal ?? Thread Starter — ronmexico78 Forum — Polaris Replies — 5 Last Post — 02-22-2009 10:04 AM
Thread — Belt squeal? whats up? Thread Starter — ZL50068 Forum — Mountain/Deep Powder Replies — 15 Last Post — 12-06-2007 03:03 PM

All times are GMT -6. The time now is 04:37 AM.

no new posts