For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: M Series 2005-Current, all models in the M-series chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-26-2018, 07:37 PM
ratherbehunting ratherbehunting is offline
Currently: Not set.
Join Date: Dec 2008
Location: Kamloops BC Canada
Basic Member
Posts: 13
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
ratherbehunting is an unknown quantity at this point
Default M8 Turbo Stutters

I've got a 2010 M8 162"
I installed a Cutler stage 3 turbo
Had no success with the Attitude controller
Running a Redline controller for the secondary injectors
Using the stock ECU with a Power Commander V and Autotune for the primaries.
The build runs very strong except it has a stutter that starts about 3750 RPM, maxs at 4000 and goes away around 4250 RPM.
Clutch engages at 3500 RPM.

I run 70% AV gas and 30% 94 with no detontation.

This stuttering appears to get worse with altitude which makes me think its rich.
I changed the Air/Fuel ratios from 13.5 to 15 and it ran much better but still stutters at altitude (5,000 ft plus).
I've been watching my pyrometers and we are not going over temp in that RPM range.
NGK BR9 plugs look coffee and cream. Turbo side pyro reads over 100C cooler than the clutch side at times. Others times very similar. Clutch side plugs very slightly lighter than the turbo side.

Any suggestions?
Go to 16/1 AF?
My map jumps to 12.5/1 under boost which occurs at about 4500 RPM. I thought the A/F map would be kind of linear from 16/1 to 12.5/1 but it's looking like more of a step from 15 (16)/1 to 12.5/1.
Anybody got experience with this?

Thanks In Advance!

Last edited by ratherbehunting; 03-26-2018 at 07:39 PM.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-28-2018, 11:58 AM
jim jim is online now
Currently: Keyboard highmarking at its best.
Join Date: Nov 2007
Location: Boise
Posts: 719
Thanks: 49
Thanked 261 Times in 123 Posts
Rep Power: 0
jim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond reputejim has a reputation beyond repute
Default

Is it constant or intermittent?

I had a similar issue with my boondocker set-up with underhood intake. The hot air would send it into a rich bog-out that it sometimes would not recover from...same RPM range. Once I went to a cold air intake, I never had the problem again and the throttle response and overall power and all improved. Runs consistent day after day. And I can run less octane without detonation. Boondocker pump gas set-up, FYI.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 04-10-2018, 08:47 AM
Hardass's Avatar
Hardass Hardass is offline
Currently: Not set.
Join Date: Nov 2007
Location: Troy Montana
Posts: 3,956
Thanks: 273
Thanked 333 Times in 254 Posts
Rep Power: 21474850
Hardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond reputeHardass has a reputation beyond repute
Default

Quote:
Originally Posted by ratherbehunting View Post
I've got a 2010 M8 162"
I installed a Cutler stage 3 turbo
Had no success with the Attitude controller
Running a Redline controller for the secondary injectors
Using the stock ECU with a Power Commander V and Autotune for the primaries.
The build runs very strong except it has a stutter that starts about 3750 RPM, maxs at 4000 and goes away around 4250 RPM.
Clutch engages at 3500 RPM.

I run 70% AV gas and 30% 94 with no detontation.

This stuttering appears to get worse with altitude which makes me think its rich.
I changed the Air/Fuel ratios from 13.5 to 15 and it ran much better but still stutters at altitude (5,000 ft plus).
I've been watching my pyrometers and we are not going over temp in that RPM range.
NGK BR9 plugs look coffee and cream. Turbo side pyro reads over 100C cooler than the clutch side at times. Others times very similar. Clutch side plugs very slightly lighter than the turbo side.

Any suggestions?
Go to 16/1 AF?
My map jumps to 12.5/1 under boost which occurs at about 4500 RPM. I thought the A/F map would be kind of linear from 16/1 to 12.5/1 but it's looking like more of a step from 15 (16)/1 to 12.5/1.
Anybody got experience with this?

Thanks In Advance!
Ecu and two different tuners holy cow what was wrong with the attitude? just curious as you have a lot going on there
__________________
M 1000 modded but no turbo no way Uh well maybe
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Video: Turbo Dragon, Turbo M7, Turbo Rx-1, Turbo Apex Thread Starter — xlr8r Forum — Mountain/Deep Powder Replies — 26 Last Post — 01-03-2012 08:53 AM
Thread — FYI...INFO ON 2012 SILBER TURBO PRO RMK TURBO KITS Thread Starter — mountainhorse Forum — Polaris: TURBO Replies — 31 Last Post — 09-17-2011 11:16 AM
Thread — 07 rev stutters Thread Starter — markoo Forum — Ski-Doo: REV Sleds Replies — 1 Last Post — 02-03-2011 11:02 AM
Thread — DEEP POWDER VIDS - Turbo Apex, Turbo Nytro, Turbo Rx-1 Thread Starter — xlr8r Forum — Mountain/Deep Powder Replies — 77 Last Post — 03-27-2008 06:36 PM

All times are GMT -6. The time now is 08:21 AM.

no new posts