For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: Pro-Ride 2010 and up, all models in the Pro-Ride chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 04-23-2018, 03:55 PM
Packer Packer is offline
Currently: Not set.
Join Date: Nov 2007
Location: Minnesota
Basic Member
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Packer is an unknown quantity at this point
Default 14 Pro 800 motor removal and install

I took the motor out of my sled to do a little tunnel repair and putting the motor back in I have 2 questions:

1. Do I need to do anything to make sure oil flow is happening? I didn't disassemble the motor or anything I just unhooked the oil line off the oil bottle.

2. Any tricks to making sure all the air is out of the coolant system? I opened up the bleeder screw on the top of the motor until coolant came out, but want to make sure.

Thanks in advance!

Packer
Reply With Quote


Rate this post: Yes | No
  #2  
Old 04-23-2018, 09:52 PM
sledhed's Avatar
sledhed sledhed is online now
Currently: Last ride of the season 5/25/18...
Join Date: Dec 2001
Location: Lolo, Montana
Posts: 1,281
Thanks: 223
Thanked 248 Times in 192 Posts
Rep Power: 20128747
sledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond repute
Post

This is what I typically do (Dragon, should apply to Pro as well):
- Premix your first tank of fuel at 50:1 for safety.
- Assuming you plugged the oil line, let oil run out of the line until bubbles are gone, and then hook it up to the oil pump. Recommend replacing your oil line filter while you are in there.
- I believe the Pro pump has an oil bleed screw (CFI-4 motor did), open it up until no more bubbles come out
- Cooling system - elevate the front of the sled, start it and heat cycle it several times and bleed out the air each time, at least warm it up enough to open the thermostat to start circulation.
__________________
Snowest forums member since December 19, 2001...
15 Pro 800 Orange Madness, Kurts gear-down and clutching, Camo Extreme 2.5x155, orange ultimate bumpers, WE clickers with Raptor triple rates, FTX kit, e-start, Ultra-Q can, Holz venting
Member:Missoula SnowgoersMontana Snowmobile Association
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 05 Fusion VR removal/install Thread Starter — sloan188 Forum — Polaris: 900 Replies — 9 Last Post — 02-14-2012 07:29 PM
Thread — 06' IQ Rolling Chassis with Motor plate & Pipes for BB 800 Install Thread Starter — BlowinSmoke Forum — Chassis/Tunnel (Swapmeet) Replies — 0 Last Post — 10-19-2011 09:29 AM
Thread — Removal of old flywheel and install of new one Thread Starter — go high fast Forum — Polaris: EDGE Replies — 3 Last Post — 08-13-2011 08:32 AM
Thread — FTX Polaris Pro Motor plate install video Thread Starter — R_8_N Forum — Polaris: Pro-Ride Replies — 6 Last Post — 01-05-2011 07:30 AM
Thread — Secondary removal and re-install Thread Starter — paramuir Forum — Polaris: 900 Replies — 17 Last Post — 02-22-2010 10:41 PM

All times are GMT -6. The time now is 06:03 AM.

no new posts