For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Ski-Doo: REV Sleds 2004.5-200, all models in the REV chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 02-21-2018, 07:00 PM
xlr88 xlr88 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
xlr88 is an unknown quantity at this point
Default 2004 MXZ 600HO no spark

I have a 2004 600HO MXZ, flipped it over, 100 miles later lost lights and shortly thereafter, lost spark. Install new aftermarket stator, and ski-doo voltage regulator. It ran for a short while, lights then went very dim, and engine died and no spark. When it was running if I changed from high to low beam, the speedometer warning lights would come on. Stator test at .3 ohms, manual cranking voltage 4.3 volts between the yellows and the yellow - green. Trigger coils 254 & 255 ohms, ignition coil primary .8 ohms, 17.3 K ohms. Any thoughts. Don't know if the events are related of if I have multiple issues that were not all solved.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 02-22-2018, 07:44 AM
cubby's Avatar
cubby cubby is offline
Currently: Riding Atv's till the snow comes back
Join Date: Nov 2007
Posts: 2,035
Thanks: 234
Thanked 265 Times in 173 Posts
Rep Power: 21474849
cubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond repute
Default

Try replacing the relay on the left side tower brace above the clutches. Bet it fixes it.
__________________
2016 T3 154"
2007 XRS 800 151" engine built by SHR
2013 Polaris 850xp
2015 Polaris 1000xp
2016 Polaris 170 RZR

Hold it pinned till you feel bad
Reply With Quote


Rate this post: Yes | No
  #3  
Old 02-22-2018, 09:23 AM
xlr88 xlr88 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
xlr88 is an unknown quantity at this point
Default

Quote:
Originally Posted by cubby View Post
Try replacing the relay on the left side tower brace above the clutches. Bet it fixes it.
thanks I'll try that but thought the relay was for lights and accessories not running and spark.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to xlr88 For This Useful Post:
xlr88 (02-22-2018)
  #4  
Old 02-22-2018, 04:04 PM
cubby's Avatar
cubby cubby is offline
Currently: Riding Atv's till the snow comes back
Join Date: Nov 2007
Posts: 2,035
Thanks: 234
Thanked 265 Times in 173 Posts
Rep Power: 21474849
cubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond reputecubby has a reputation beyond repute
Default

My buddies 08 ran like crap and hand warmers quit, no lights check engine light came on all kinds of things. But that fixed his, and it's where I would start if I was you. Get one at Napa or some other car parts store. BRP wants $50 for theirs.
__________________
2016 T3 154"
2007 XRS 800 151" engine built by SHR
2013 Polaris 850xp
2015 Polaris 1000xp
2016 Polaris 170 RZR

Hold it pinned till you feel bad
Reply With Quote


Rate this post: Yes | No
  #5  
Old 02-22-2018, 08:05 PM
xlr88 xlr88 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
xlr88 is an unknown quantity at this point
Default pulled out relay, put power to lead direct short

I haven't had a chance to get a new relay but it must have been stuck shut and I had a direct short in the tail light. This was sucking all of the juice from the stator. I fixed the short and left the relay out. I haven't started it yet but I now get spark on a test spark plug. Thanks for the tip.
Reply With Quote


Rate this post: Yes | No
  #6  
Old 02-24-2018, 01:57 PM
xlr88 xlr88 is offline
Currently: Not set.
Join Date: Feb 2018
Basic Member
Posts: 5
Thanks: 1
Thanked 1 Time in 1 Post
Rep Power: 0
xlr88 is an unknown quantity at this point
Default How many amps should hand and thumb warmers take

I fixed the tail light short, replaced the relay, it starts and runs, but the main wires get warm after a short run time. As I start to turn on the grips and thumb warmer I get dash warning lights. My guess something is still drawing too much elec and those lights come on with lower voltage. Where is a good spot to test the system voltage? How much may amps should the grips take and how much for the thumb warmer? High and low settings. This is all on 2004 REV mxz Adrenaline 600HO.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Tags
no lights, no spark, speedo warning lights

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 04 600HO REV MXZ RENEGADE Thread Starter — n2otoofast4u Forum — Ski-Doo (Swapmeet) Replies — 4 Last Post — 10-23-2012 12:59 AM
Thread — 2002 MXZ 600 no spark Thread Starter — firstsled Forum — Ski-Doo: ZX Sleds Replies — 0 Last Post — 11-30-2011 10:45 PM
Thread — 05 mxz 800 ho powertek no spark Thread Starter — Akadien Forum — Ski-Doo: REV Sleds Replies — 2 Last Post — 11-16-2011 09:09 PM
Thread — 2002 mxz no spark? Thread Starter — doozack Forum — Ski-Doo: ZX Sleds Replies — 4 Last Post — 01-30-2011 09:33 AM
Thread — 2003 MXZ Rev 600HO, 1106miles Thread Starter — jimmygerhardson Forum — Ski-Doo (Swapmeet) Replies — 1 Last Post — 02-14-2008 02:15 AM

All times are GMT -6. The time now is 02:59 AM.

no new posts