For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: TURBO Turbo discussion for Arctic Cat aftermarket turbo sleds
Reply
 
Share Thread Tools Display Modes
  #1  
Old 01-13-2018, 12:08 PM
Jetcjcski Jetcjcski is offline
Currently: Not set.
Join Date: Dec 2012
Basic Member
Posts: 5
Thanks: 6
Thanked 0 Times in 0 Posts
Rep Power: 0
Jetcjcski is an unknown quantity at this point
Default 2012 M8, Push Turbo, PCV Won't stay running

Got the turbo installed over the week. Now I'm at the parking lot in the mountains and can't get it to run for more than 10-20 seconds.

Adjusted TPS to .684 closed, 3.5 open.

Leaned the fuel trim down to make it run, seems to braap well when running but just shuts off like a kill switch. Fires back up no problem.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-16-2018, 09:47 AM
Fish10782 Fish10782 is offline
Currently: Trolling P-Hub
Join Date: Nov 2017
Location: Nevada
Basic Member
Posts: 74
Thanks: 3
Thanked 18 Times in 13 Posts
Rep Power: 572552
Fish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond repute
Default

I had mine quit on me a few times like this. I leaned it out with the pod 300 to get it to run up in the mountain. BUT randomly it stopped running. Towed it back home, wouldn't start on the trailer, dragged it into the shop, and it fired up.

My best guess is that I had some wires pulled to tight. I disassembled everything, dialectic grease on every connecting, and secured all the wiring with a little bit more slack towards the ecm/ pc5. I haven't had an issue since, but have not had a ton of run time on it yet either.

Also make sure it's not your throttle safety switch shutting you down.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 01-16-2018, 09:50 AM
Fish10782 Fish10782 is offline
Currently: Trolling P-Hub
Join Date: Nov 2017
Location: Nevada
Basic Member
Posts: 74
Thanks: 3
Thanked 18 Times in 13 Posts
Rep Power: 572552
Fish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond repute
Default

My tps is at .413 closed, .710 idle, 3.7 full open
Reply With Quote


Rate this post: Yes | No
  #4  
Old 01-27-2018, 02:26 PM
Fish10782 Fish10782 is offline
Currently: Trolling P-Hub
Join Date: Nov 2017
Location: Nevada
Basic Member
Posts: 74
Thanks: 3
Thanked 18 Times in 13 Posts
Rep Power: 572552
Fish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond reputeFish10782 has a reputation beyond repute
Default

You throwing any ecu codes?
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 72 elan won’t stay running Thread Starter — MSP381 Forum — Vintage Replies — 4 Last Post — 12-25-2017 07:52 PM
Thread — Fires but won't stay running?? Thread Starter — snopro176 Forum — Arctic Cat: Proclimb M Replies — 8 Last Post — 12-22-2015 12:18 PM
Thread — 900 won't stay running Thread Starter — t_tardi Forum — Polaris: 900 Replies — 1 Last Post — 12-28-2012 12:00 PM
Thread — *********09 D8 won't stay running need help********** Thread Starter — 05iq900 Forum — Polaris: IQ Replies — 4 Last Post — 02-06-2012 02:26 PM
Thread — M8 Won't stay running Thread Starter — lafelafe2 Forum — Arctic Cat Replies — 4 Last Post — 01-26-2009 06:34 PM

All times are GMT -6. The time now is 11:39 PM.