For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: IQ 2005-Current, all models in the IQ and IQ Raw chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-17-2017, 07:44 PM
tryanattak tryanattak is offline
Currently: Waiting for snow
Join Date: Oct 2009
Basic Member
Posts: 50
Thanks: 16
Thanked 3 Times in 3 Posts
Rep Power: 2917
tryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to behold
Default Intermittent bog.

I have a bog that happens right around 7500 rpm. It however does not happen all the time. I have put a new fuel filter in it, new power valve Springs, cleaned the power valves, adjusted the throttle cable play. It had a broken power valve spring so I thought that was the issue but nope. We have plugged the emission hoses on the power valves and left the solenoid alone . Sometimes the bog occurs at slamming the throttle open, sometimes it accelerates just fine. If it does bog most often feathering the throttle gets it past the big and it just rips. It is a 2009 600 efi rmk shift 155. I have bought new 64 grams weights but have not tried that yet. We were thinking it maybe the TPS but it does not throw a code at all nor does the light flash even. The power status bar on the dash shows full charging all the time. Does anyone have any other ideas? Like I said it is Intermittent sometimes it will run for several.minutes without a big issue at all. Other times it bogs several times in a row. If you feather through it and it clears up then it seems most times tof be alright for a bit. This is driving me nuts. I wish it had carbs right now.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 03-17-2017, 08:39 PM
slash's Avatar
slash slash is offline
Currently: ahhh back to work
Join Date: Jul 2008
Location: IDAHO FALLS 83404
Parts Moderator & Chat Box Cop
Age: 59
Posts: 2,738
Thanks: 552
Thanked 715 Times in 492 Posts
Rep Power: 21474849
slash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond repute
Garage
Default

check the rollers in your 2ed clutch mine had the same problem bad roller
__________________

09 IQ
KMOD
RAPTORS
2.5 CE
MOHAWKS
SLP PIPE
KOOLME KUSTOMS 660 KIT
TATERSPORTING PORTWORK

[IMG]//www.snowest.com//www.snowest.com/i/snowest-forum-logo.jpg[/IMG]
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to slash For This Useful Post:
tryanattak (03-17-2017)
  #3  
Old 12-10-2017, 07:39 PM
tryanattak tryanattak is offline
Currently: Waiting for snow
Join Date: Oct 2009
Basic Member
Posts: 50
Thanks: 16
Thanked 3 Times in 3 Posts
Rep Power: 2917
tryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to behold
Default

Well I installed the 64 gram weights in the primary. It did not make it any better if anything it got worse. We tried unplugging the O2 sensor and it made it more sluggish when blipping throttle but did not flash the engine light at all. We basically did this to check if the engine light would flash as it does not do it like my son's 05 RMK would. He had a TPS issue and his flashed the light. Would a fuel commander over ride the TPS. I forgot to mention the sled does have a MRBP can on it. Is it possible that could be making the bog issue? I am not sure if the previous owner had any issues but the can was on it when I got it. As I have stated it does not bog all the time, sometimes you hit the throttle and it rips right away other times it hits a dead spot then goes. My readout shows I have hit 8300 rpm as a max. The bog seems to happen right at 6750 now thinking that could be the new 64 gram weights it had the 58 gram weights from the factory in it. Any help would be appreciated, thanks.
Reply With Quote


Rate this post: Yes | No
  #4  
Old 12-23-2017, 12:59 PM
peaceofwork peaceofwork is offline
Currently: Internet Rmkpro 800apprentiship
Join Date: Nov 2016
Location: In the shop or in the bush
Basic Member
Posts: 320
Thanks: 30
Thanked 23 Times in 21 Posts
Rep Power: 308610
peaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond repute
Default

I had an assult 800 cutting out at 7000 ,the cause was a torn bellow in the power valve . I got segestions like clean the power valves and run a wire up in the cylinder to make sure the port is clear and same for the valve it's self.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to peaceofwork For This Useful Post:
tryanattak (12-27-2017)
  #5  
Old 12-23-2017, 09:56 PM
volcano buster volcano buster is online now
Currently: Not set.
Join Date: Nov 2007
Location: Stayton Oregon
Age: 48
Posts: 3,419
Thanks: 872
Thanked 699 Times in 474 Posts
Rep Power: 0
volcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond repute
Default

I've got a '10 660 that bogs at WOT after a while. I was out Thursday and was running WOT in about 2' of fluff on the road. It would start to cut out like I was losing fuel pressure to at least a couple of the injectors (4 total). Let out, back into it a couple times and it would hammer back up to max R's.

I plan to pull the fuel pickup out of the tank and see if there is anything funny going on in there.
Reply With Quote


Rate this post: Yes | No
The Following User Says Thank You to volcano buster For This Useful Post:
tryanattak (12-27-2017)
  #6  
Old 12-24-2017, 01:23 PM
tryanattak tryanattak is offline
Currently: Waiting for snow
Join Date: Oct 2009
Basic Member
Posts: 50
Thanks: 16
Thanked 3 Times in 3 Posts
Rep Power: 2917
tryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to behold
Default

We did all the suggested fixes. We cleaned the valves, put new bellows and valve springs in it. We adjusted the throttle cable play to spec, we ran a stiff piece of wire through the purge hole, we replaced the fuel filter, put 64 gram weights in the primary clutch. It still has the intermittent bog issue. It now happens at 6500-6750 rpm range. Above and below that their is no issue. Sometimes it just rips right on through that area and other and most times it hesitates or bogs in the mentioned range.
I have been researching this like crazy and I think my answer may be the lazy power valve issue. The purge hole needs to be enlarged and go back to the lighter weight power valve springs. I even tried a dyne jet fuel commander, it helped in the problem rpm range greatly but messed up the bottom end. I will eventually pull the head and drill out the purge hole to the bigger size and see if tha indeed fixes it.
Reply With Quote


Rate this post: Yes | No
  #7  
Old 12-24-2017, 02:54 PM
volcano buster volcano buster is online now
Currently: Not set.
Join Date: Nov 2007
Location: Stayton Oregon
Age: 48
Posts: 3,419
Thanks: 872
Thanked 699 Times in 474 Posts
Rep Power: 0
volcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond reputevolcano buster has a reputation beyond repute
Default

4 injector motor?
Reply With Quote


Rate this post: Yes | No
  #8  
Old 12-24-2017, 04:16 PM
peaceofwork peaceofwork is offline
Currently: Internet Rmkpro 800apprentiship
Join Date: Nov 2016
Location: In the shop or in the bush
Basic Member
Posts: 320
Thanks: 30
Thanked 23 Times in 21 Posts
Rep Power: 308610
peaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond reputepeaceofwork has a reputation beyond repute
Default

Quote:
Originally Posted by volcano buster View Post
4 injector motor?
Probably 2010 or older cfi like a dragon ?
Reply With Quote


Rate this post: Yes | No
  #9  
Old 12-25-2017, 02:41 PM
tryanattak tryanattak is offline
Currently: Waiting for snow
Join Date: Oct 2009
Basic Member
Posts: 50
Thanks: 16
Thanked 3 Times in 3 Posts
Rep Power: 2917
tryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to behold
Default

No the 2009 RMK shift 155 is the CFI2 engine. We just today pulled it apart again and found the spring on the mag side was broken again. I just replaced the springs last season and only have put maybe 200 miles on those springs. I cleaned everything again, ran a wire through all the purge holes, and installed new springs again. It seems better but still happens.
Reply With Quote


Rate this post: Yes | No
  #10  
Old 12-26-2017, 09:04 PM
retiredpop retiredpop is offline
Currently: Not set
Join Date: Jul 2001
Location: Calgary
Posts: 1,074
Thanks: 97
Thanked 189 Times in 170 Posts
Rep Power: 8732232
retiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond reputeretiredpop has a reputation beyond repute
The Following User Says Thank You to retiredpop For This Useful Post:
tryanattak (12-27-2017)
  #11  
Old 12-26-2017, 10:10 PM
sledhed's Avatar
sledhed sledhed is offline
Currently: Last ride of the season 5/25/18...
Join Date: Dec 2001
Location: Lolo, Montana
Posts: 1,252
Thanks: 219
Thanked 245 Times in 190 Posts
Rep Power: 20128747
sledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond reputesledhed has a reputation beyond repute
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

The Following User Says Thank You to sledhed For This Useful Post:
tryanattak (12-27-2017)
  #12  
Old 12-27-2017, 12:48 AM
tryanattak tryanattak is offline
Currently: Waiting for snow
Join Date: Oct 2009
Basic Member
Posts: 50
Thanks: 16
Thanked 3 Times in 3 Posts
Rep Power: 2917
tryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to beholdtryanattak is a splendid one to behold
Warning You Must be a registered member and logged in to view this response.

Click Here to Register

Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 08 Dragon - strange intermittent bog Thread Starter — sledhed Forum — Polaris: IQ Replies — 18 Last Post — 11-16-2017 09:34 AM
Thread — '15 intermittent bog Thread Starter — TRS Forum — Polaris: Pro-Ride Replies — 11 Last Post — 01-12-2017 08:21 PM
Thread — Intermittent Bog on 13 EM Thread Starter — offtrail Forum — Ski-Doo: XM Sleds Replies — 23 Last Post — 03-30-2013 10:19 AM
Thread — Intermittent Bogging? Thread Starter — tonyl748 Forum — Ski-Doo: XP Sleds Replies — 4 Last Post — 03-13-2013 01:09 AM
Thread — intermittent bog Thread Starter — wi.switchback Forum — Polaris: Pro-Ride Replies — 8 Last Post — 01-02-2013 12:41 PM

All times are GMT -6. The time now is 04:21 PM.