For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Reply
 
Share Thread Tools Display Modes
  #1  
Old 11-15-2017, 11:56 PM
dopey333 dopey333 is offline
Currently: Not set.
Join Date: Sep 2013
Basic Member
Age: 25
Posts: 40
Thanks: 0
Thanked 2 Times in 2 Posts
Rep Power: 0
dopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant futuredopey333 has a brilliant future
Default 2013 1100 wont start

So after replacing my chaincase and doing an oil change my sled wont start. fuel pump is working followed all the correct steps and it started for 1 second then died and wouldnt fire again the only thing i can think is to try replacing the spark plugs. Any suggestions/thoughts we checked all fuses relays wiring and everything is where it should be the only thing i can think of is spark plugs. if so does the tank have to come off to replace them?
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 2013 XM 800 wont start on incline? Thread Starter — yzviper366 Forum — Ski-Doo: XM Sleds Replies — 5 Last Post — 01-20-2016 09:15 PM
Thread — xm's wont start Thread Starter — jjdad Forum — Ski-Doo: XM Sleds Replies — 5 Last Post — 11-30-2015 12:53 PM
Thread — HELP: Why wont it start? Thread Starter — SnoSleds Forum — Arctic Cat: Powder Special and older Replies — 4 Last Post — 07-18-2013 06:59 AM
Thread — 2013 sno pro ran out of gas wont start Thread Starter — cmatt Forum — Arctic Cat: Proclimb M Replies — 3 Last Post — 01-19-2013 06:51 PM
Thread — M7 wont start! Thread Starter — dancat Forum — Arctic Cat Replies — 6 Last Post — 01-19-2008 08:07 PM

All times are GMT -6. The time now is 01:03 PM.