For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Polaris: GEN 2 1999-2001, all models in the Gen 2 chassis
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-03-2016, 04:34 PM
alaska_guy alaska_guy is offline
Currently: Waiting for snow
Join Date: Oct 2014
Basic Member
Posts: 105
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 467430
alaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond repute
Default Just fired my sled up and took it for a short ride after rebuild...

So I jetted per SLP's recommendations and I just had a quick question.

My EGT guage was showing 8 on the left side and 4 on the right side. Is it normal for these twins to be unbalanced on the EGT guage? Sled rips, but just want to make sure I don't mess anything up since I just rebuild it last year and this is the first time I have been able to really ride the machine since it was rebuilt. I didn't really ride it hard or WOT, just around the block for about 10 minutes or so. Seemed around 400-600 at idle.

2001 RMK, SLP twins, ported and polished.

Thanks!

It feels a little sluggish down low too... I know with twins they can do that, but just wanted to make sure I don't need to switch jets up another size since one side is showing a lower EGT which I assume means it's running lean.

My sled does have staggered main jetting per SLP's recommendation. One side is 20 higher than the other.

Last edited by alaska_guy; 12-03-2016 at 05:03 PM.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 12-03-2016, 06:07 PM
alaska_guy alaska_guy is offline
Currently: Waiting for snow
Join Date: Oct 2014
Basic Member
Posts: 105
Thanks: 0
Thanked 5 Times in 4 Posts
Rep Power: 467430
alaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond reputealaska_guy has a reputation beyond repute
Default

I think I got it fellas. I was running 470 mains. Switched them to 500's and the sled is running MUCH better. No more bog down low.

http://www.startinglineproducts.com/...ets/09-726.pdf

I used that as a guide. I run around 300-500 elevation and 0-14 degrees on average for temp.
Reply With Quote


Rate this post: Yes | No
  #3  
Old 12-04-2016, 04:40 PM
slash's Avatar
slash slash is offline
Currently: ahhh back to work
Join Date: Jul 2008
Location: IDAHO FALLS 83404
Parts Moderator & Chat Box Cop
Age: 59
Posts: 2,738
Thanks: 552
Thanked 715 Times in 492 Posts
Rep Power: 21474849
slash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond reputeslash has a reputation beyond repute
Garage
Default

higher EGT number is lean, lower or cold number is rich .
keep it below 1200 and you should be ok
mid throttle cruse @ 900 to 1000 deg is good .
always DBL check your plug reading ..
__________________

09 IQ
KMOD
RAPTORS
2.5 CE
MOHAWKS
SLP PIPE
KOOLME KUSTOMS 660 KIT
TATERSPORTING PORTWORK

[IMG]//www.snowest.com//www.snowest.com/i/snowest-forum-logo.jpg[/IMG]
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — Polaris 600 CFI Short block needs rebuild Thread Starter — GNDAN Forum — Engine/Engine Parts (Swapmeet) Replies — 9 Last Post — 01-19-2015 06:34 PM
Thread — Are you as FIRED up as this guy was to ride his new M1100T? Thread Starter — Jeff C Forum — Arctic Cat: 1100 ProClimb Replies — 35 Last Post — 12-14-2011 05:04 PM
Thread — rebuild crank or BRP short block? Thread Starter — mental health Forum — Ski-Doo: REV Sleds Replies — 14 Last Post — 09-21-2011 10:40 PM
Thread — Snowies - who's still fired up to ride? Thread Starter — Coldfinger Forum — Wyoming Replies — 31 Last Post — 05-08-2010 10:54 AM
Thread — Tacoma Double Cab Short Bed: Too short for sled? Thread Starter — JJ Forum — General Snowmobiling Replies — 14 Last Post — 06-13-2008 02:40 PM

All times are GMT -6. The time now is 07:42 PM.