For support please email or pm Christopher christopher@snowestonline.com



Upgrade to Premium
Arctic Cat: Powder Special and older 2000 and older, all models in the Powder Special chassis and older chassis models
Reply
 
Share Thread Tools Display Modes
  #1  
Old 12-27-2014, 07:47 PM
JordanWilliams JordanWilliams is offline
Currently: Not set.
Join Date: Sep 2013
Location: Eastern South Dakota
Posts: 61
Thanks: 8
Thanked 2 Times in 2 Posts
Rep Power: 214753
JordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond reputeJordanWilliams has a reputation beyond repute
Default 97 zr580 flooding/ecu blinks once

I have a 97 zr580 I just put together. Won't run. Loads full of gas. Any suggestions? Has spark injectors have been checked has fuel to the rail. Tps sensor or coolant temp. Sensor? Got the sled in a box of parts. Everything is here. Starts to Fire but won't stay running.
Reply With Quote


Rate this post: Yes | No
  #2  
Old 01-20-2016, 04:07 PM
ullmelt ullmelt is offline
Currently: Not set.
Join Date: Jan 2016
Location: Billings Mt
Basic Member
Age: 54
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
ullmelt is an unknown quantity at this point
Default

If you can, remove the pipe from the Y pipe, and unplug your injectors. Pull it several times with the key on kill switch up, this will clear the case. Assuming you have new good gas in it. When the crankcase and pipe load with fuel they are impossible to start. Once it starts to idle, plug your injectors back in and slowly push the pipe to the y pipe to let it start to clear out. It has happened to me a few times. Reinstall exhaust springs after it is cleared up. If that isn't it, then start ohm testing as stater, tps... checking electrical.
Reply With Quote


Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Thread — 1997 Arctic Cat ZR580 Thread Starter — almostaranch2001 Forum — Arctic Cat (Swapmeet) Replies — 1 Last Post — 03-08-2010 12:56 PM
Thread — WTB zr580 stock pipe. Thread Starter — zak Forum — Arctic Cat Replies — 0 Last Post — 10-21-2009 12:15 AM
Thread — 5 Check engine blinks??? Thread Starter — jsledder Forum — Polaris Replies — 2 Last Post — 03-02-2009 09:43 PM
Thread — 97 zr580 efi - parting out Thread Starter — XP70069 Forum — Misc. Sled Parts Replies — 0 Last Post — 08-30-2008 07:31 AM

All times are GMT -6. The time now is 07:03 AM.