SnoWest Snowmobile Forum

SnoWest Snowmobile Forum (https://www.snowest.com/forum/index.php)
-   Ski-Doo: XM Sleds (https://www.snowest.com/forum/forumdisplay.php?f=355)
-   -   Any cures from the dreaded hesitation or bog? (https://www.snowest.com/forum/showthread.php?t=440248)

2dedge 02-05-2018 06:07 PM

Any cures from the dreaded hesitation or bog?
 
2014 freeride fresh motor, updates supposedly done, timing bumped 1 degree, oil pump turned up 1 setting, ran back through break in, new fuel filter, fuel pressure verified as good holds 45 psi even when running poorly, 2 new sets of plugs also.

Hold it wide open and try to make a climb and it will bog and fall on its face, rpms drop to 7000 for a few moments then it starts pulling again, but your usually stuck by then.

Run it down the trail and it pulls to 8000 runs great, if you let off and get back into it and it coughs and farts around 6800/7000, if you keep holding it wide open it will sometimes clean out and pull to 8000. If you let off and rpms go back down to 4K it will pull to redline like crazy again.

It is not throwing any codes I had the dealer scan it, it’s not hitting the rev limiter.

I did find one post that said “loose ground wire for the oil pump feedback switch”
Was one guys cause but what is the oil pump feedback switch?

Any other cures?

2dedge 02-05-2018 06:20 PM

Stock exhaust

Goinboardin 02-05-2018 08:19 PM

Been through your clutches? I get pretty bad hesitation if the motor isn't loaded heavily, like from hanging fly weight, sticking movable sheave, or even insufficient pin weight.

swovay696 02-07-2018 08:45 PM

Stator! 12'-13´ etec. It's not if, it's when. Sounds like common symptoms I had, buddy had, and what I've read on other forums. Google it

Superduty348 02-25-2018 09:02 PM

rave valve solenoid I bet.... had very similar issues, changed and it was gone

butthead 03-11-2018 09:46 AM

i just had the same problem
took off black rave cover
2 8m socket screws
were about 2 turns loose each
bog solved

BC_mtn_rider 02-23-2019 01:33 PM

My 15 T3 bogs now only when pulling a hill or under load. Once she hits around 55-6000 she bogs right down. Rips totally normal on the flats & trails. Had the FPR done under warranty, put new plugs in & fuel filter. Still falling on its face. Checked Reeds & Rave Valves & gonna try another Can. Also, its not throwing any codes. So frustrating.

winter brew 02-25-2019 02:37 PM

Fuel pressure regulator loose? Load the clutches harder (try clicking down to see if it helps or eliminates), Raves as mentioned, try stock exhaust if it is not already. All of the above can induce a bog/hesitation.

BC_mtn_rider 02-27-2019 08:59 PM

Through process of elimination & over $700 spent the only thing left is my fuel pick up or fuel pump. My guess is the pick-up.

kanedog 02-27-2019 09:09 PM

Quote:

Originally Posted by BC_mtn_rider (Post 4203539)
My 15 T3 bogs now only when pulling a hill or under load. Once she hits around 55-6000 she bogs right down. Rips totally normal on the flats & trails. Had the FPR done under warranty, put new plugs in & fuel filter. Still falling on its face. Checked Reeds & Rave Valves & gonna try another Can. Also, its not throwing any codes. So frustrating.

Have a peak at your secondary rollers.

Sent from my SM-G920W8 using Tapatalk


All times are GMT -6. The time now is 12:25 PM.


All contents copyright 2007-2017, SnoWest Magazine, Harris Publishing Inc.