View Full Version : 2006 M7 efi JUST DIES ON TRAIL NO SPARK! HELP!

01-08-2013, 11:13 PM
ok, so I got a used m7 06 and I was riding got about 2 miles up the trail and it just dies like I hit the kill switch, so I check and I didn't, after about 20 minutes of diagnosing on the trail, no luck. so we unplug the handlebar controls and still nothing. so we take it home and we swap parts including stator, ignition timing sensor, fuel pump, ecu. and we still have no spark, all parts work on the other sled. any ideas??? help!:face-icon-small-sad:face-icon-small-sad

01-08-2013, 11:25 PM
water in connector or worn wire some place.

01-09-2013, 01:24 AM
you look at the coil?

01-09-2013, 07:09 AM
Check the tail light wiring!

01-09-2013, 09:55 AM
Check the little clear tube that comes out of the ECU. I had mine plug from a frozen ice chunk and snuffed the sled out. There is also a sensor by the throttle lever that can go bad as well

01-09-2013, 03:20 PM
we have already switched the coil as well. we just ordered a new wiring harness, and as far as the ecu goes, it works on our doner sled! its so weird

01-09-2013, 03:21 PM
and can the tps sensor cause a no spark condition ?

01-09-2013, 03:50 PM
is it getting fuel? meaning when you pull rope fuel spit out of pump?

did you unplug the tail light

we have already switched the coil as well. we just ordered a new wiring harness, and as far as the ecu goes, it works on our doner sled! its so weird

01-09-2013, 09:33 PM
yes it has fuel pressure, like I said it just doesn't have spark

01-09-2013, 09:55 PM
Does it have a tether?? My sons M7 did the same thing in very bad spot on a sidehill. Turned out to be a bad tether switch. Baffled us for quite awhile, the tether quit working even when we pressed the switch in with a stick. I decided to cut one of the wire to the tether to see if maybe something the tether switch was bad. Sure enough, started right up and ran like a champ. Those cheap plug style tethers SUCK!!!

01-13-2013, 01:12 PM
New development, the sled will start every once in a while but for only 3 seconds max then it has no spark, and no it doesn't have a teather.

01-13-2013, 01:15 PM
is it getting fuel? meaning when you pull rope fuel spit out of pump?

did you unplug the tail light
Yes we did unplug the tail light.

01-13-2013, 01:16 PM
...how is the power valve servo wiring and back up alarm wiring...aren;t those going under the tank side to side..??.

01-13-2013, 10:10 PM
hey, just got rid of the same problem with mine, no spark then if it had spark it would run 2 seconds and no spark, i swapped ecu, timing sensor, coil, and new plugs, still nothing, so figured it was stator, so i sent mine to rm stator to get rebuilt, they charged me 180 and cost 100 shipping return and also put new timing sensor, and coil in, new plugs again, and pull the rope, still no spark.... so i find a used stator with only 20 hours onit, and put it in, still no spark,! then noticed plugs were soaked, so pulled reeds to look for broken reed, they looked good, and i look in the bottom of crank case and find it full of gas, so i venturi vacume it all out, put back together and pull rope... it runs... for 5 seconds this time and dies... plugs are dry, and no spark,, wtf now... tore wireing harness off and read contenunity between all wires end to end, they look good, put in dish washer to get hot and recheck,,, still good, put in snowbank overnight, and still look good,, put it back in sled and spark for 3 seconds, and dies.. no spark.. wtf. wiggle harness plug at ecu and unplug it a couple times, then got spark,, so i retest harness ahain, this time with alligator clips on wires, and took each wire out of ecu plug, one by one, and check them this way. bending every wire every 1/8 inch all the way to end, and looks good, !.so i start inspecting wired at ecu plug, i found the top row of wires in plug, last 3 on the right side, were dark and smelt burnt.. so i clean in muratic acid, put together, still no spark, then take them 3 out again, coat them with a cuple coats of liquid electrical tape, and let dry, then one last coat of liquid tape and shove then in theyre proper hole, push white clip on plug in, plug the harness into the ecu, and the piece of **** runs awsome,,, go for a ride, make it half a mile, and it dies.. wtf.... tow home, and i at this point wanna burn it, i then take and order a new harness , put it in, tie it up nice and tight, clean all connections, run an extra ground from stator to frame,, pull rope and noo friggin spark,,,, WTF !, im pist!, i unplug the ecu harness and slightly bend all the pins on the ecu all in the same direction, and plug it in,,, i could feel some resistance in pushing it in, it fired right up, and i rode 540km over 2 weeks, and just start to gain trust in machine again, then it suddenly died again, ... tow home, and this time it has spark, but no feul psi... so i put new pump in and shees runnin good now.. SO I WASTED MONEY ON COIL, 2 STATORS,WIREING HARNESS, SPARK PICK UP MODULE, SPARK PLUG CAPS, COUNTLESS HOURS AND FRUSTRATION, what i feel it was, was this, i thinkthe 3 wires on ecu plug were making poor contact, causing them to get warm, inturn burnt the inside of pug out causing wires to arc out between themselves, thats why the liquid electrical tape fixed this, it was only a bandaid, so a new harness was in order, but the bending of the ecu pins making shure they were all making good contact, , i think was the root of problem,, good luck.... :yo:

01-13-2013, 10:16 PM
also check with a flashlight to see if you have metalic shavings on bottom of fuel tank, if you do.. your pump is on its way out.. you can buy them from www.autoperformanceengineering.com (http://www.autoperformanceengineering.com) under there specialty pumps section, gsc 404, and retail for 115.00 :face-icon-small-coo