Engine runs rough - SnoWest Snowmobile Forum
For support please email or pm Christopher christopher@snowestonline.com

New Thread

Go Back   SnoWest Snowmobile Forum > Performance & Modifications > Polaris > Polaris: Pro-Ride


SnoWest
Register Forums New Posts Classifieds Garages


Upgrade to Premium
Polaris: Pro-Ride 2010 and up, all models in the Pro-Ride chassis

Reply
 
Share Thread Tools Display Modes
  #1  
Old 03-04-2013, 06:24 AM
Caspers62 Caspers62 is offline
Currently: Not set.
Basic Member
 
Join Date: Jan 2008
Location: Steamboat Lake
Age: 52
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Rep Power: 0
Caspers62 is an unknown quantity at this point
Default Engine runs rough

I recently purchased a 2011 800 Pro 163" with 620 miles on it. I use non-eth fuel and between 5100-5800 rpm it is not smooth, it has kind of a stammering/growling sound..give it a little more throttle and it clears out and takes off like a rocket. It makes it hard to ride in the trees at a lower RPM. Anyone else have/had this issue?
Reply With Quote
Rate this post: Yes | No
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is On

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
04 Rev 800 Runs rough at low speed Jonfo Ski-Doo: REV Sleds 5 02-02-2013 09:13 AM
04 700 runs rough 660popo Polaris: EDGE 11 01-23-2013 01:58 PM
Phazer runs rough Flakey Phazers! 9 11-28-2011 10:49 PM
09 Dragon runs rough?? 09DragonRMK Polaris: IQ 3 12-18-2010 11:40 PM
06 sdi 600 runs rough under load wot toshy Ski-Doo: REV Sleds 0 02-22-2010 09:17 AM



All times are GMT -6. The time now is 07:51 PM.


All contents copyright 2007-2014, SnoWest Magazine, Harris Publishing Inc.




SnoWest snowmobile magazine is published by Harris Publishing, Inc.
no new posts